ISCSICTL(8) System Manager's Manual ISCSICTL(8)

iscsictl
program to manage iSCSI instances

iscsictl [
-d sockdir
] command [
arguments ...
]

The iscsictl utility manages iSCSI instances on the local computer. It talks to the iscsid(8) program to perform this management.
iSCSI is a method for transferring SCSI commands across a TCP connection. The client which issues the SCSI command is called the initiator, and the device which receives the command and takes action is called the target; this mirrors SCSI devices, although instead of being physically attached to a host, the SCSI commands and responses take place over a network. iSCSI communication is done in sessions. The iSCSI initiator logs in to a target across the network, possibly authenticating itself; this creates an iSCSI session between initiator and target. The initiator can then issue commands to and read responses from the target.
Firstly, the iSCSI initiator on the local machine must be made aware of the network location of the target. The add_send_target is used in iscsictl to do this. The targets can be listed using the list_targets command. To login from the initiator to the target, the login command is used; this creates a session between the initiator and target. The sessions can be listed by using the list_sessions command.

 
 
sockdir
Specify the directory where the socket for iscsid(8) lives.

The target address specification for the add_target and add_send_target commands may include a target name, target address (IP or FQDN), TCP port, and group tag. Either the target address or target name is required. (For add_send_target, a target address is required). The address, port, and group tag may optionally be repeated.
 
 
target-address
Specify the target address by IP or FQDN.
 
 
target-name
Specify the target by name.
 
 
port-num
The TCP port to connect to the target on. (Default port is 3260)
 
 
group-tag
The group tag, a 16-bit integer.

The portal address specification for the add_portal command may include an address (IP or FQDN), port, and group tag, plus portal options.
 
 
target-address
Specify the target address by IP or FQDN.
 
 
port-num
The TCP port to connect to the target on. (Default port is 3260)
 
 
group-tag
The group tag, a 16-bit integer.
 
 
Use a CRC32 header digest.
 
 
Use a CRC32 data digest.
 
 
segment-length
Specify the max received data segment length.

Target options are as follows:
 
 
Use a CRC32 header digest.
 
 
Use a CRC32 data digest.
 
 
time
Time to wait.
 
 
time
Time to retain.
 
 
level
Error recovery level.
 
 
segment-length
Specify the max received data segment length.

Authentication options are as follows:
 
 
type
Specify authentication type. n indicates no authentication, while c indicates CHAP authentication, and C indicates Mutual CHAP authentication.
 
 
name
User name.
 
 
secret
Initiator secret.
 
 
secret
Target secret.

Commands

The iscsictl command argument is taken from one of the following options:
 
 
return version information from the iscsictl utility and the iscsid(8) daemon.
 
 
target-address-spec [
target-opts
] [
auth-opts
] [
-N symbolic-name
]
A target-address-spec may include name, address, port, and group tag, with address/port/tag possibly repeated.
 
 
portal-address-spec [
-I -target-id
] [
-N -symbolic-name
]
Add a portal to the list of portals.
 
 
-I target-id
 
-n target-name
Remove a target by name or ID.
 
 
Not implemented.
 
 
[
-I target-id
]
this command causes the iSCSI initiator to refresh its view of the iSCSI targets to which it is connected. If this command completes successfully, an “OK” value is printed. For more context on the exact usage of this command, please see the example below.
 
 
Display a list of targets the iSCSI initiator knows about.
 
 
-a target-address [
target-address-spec
] [
target-opts
] [
auth-opts
] [
-N symbolic-name
]
this command allows the iSCSI initiator to connect to an iSCSI target. The subsequent -a target provides the address of the target. This can be provided as a numerical IP address, or as a textual FQDN. For more context on the exact usage of this command, please see the example below.
 
 
-I target-id
 
-n target-name
Remove a send target from the list by name or target-id
 
 
Display the list of send targets configured.
 
 
iSNS-address-spec
Add an iSNS server using an address specification that may include name, address, and port.
 
 
-I isns-server-id
 
-a isns-server-address
 
Not Implemented.
 
 
 
[
-I id
]
 
[
-m
] [
target-opts
] [
auth-opts
] [
-P portal-id
]
To be able to communicate with the iSCSI target, the initiator must login. This command allows this login to take place. The subsequent -P session argument provides the session which should be used to perform the login. On successful completion of this command, the session which has been created will be displayed, along with the connection number. For more context on the exact usage of this command, please see the example below.
 
 
[
-I session-id
]
 
[
-m
] [
target-opts
] [
auth-opts
] [
-P portal-id
]
 
-I session-id -C connection-id
 
[
-l lun
] [
-d detail
] [
-p pag
]
 
[
-I session-id [
-l lun
]
]
 
[
-I session-id
]
 
[
-I session-id
]
 
-a interface-address [
-N symbolic-name
]
 
-I portal-id
 
 
[
-c
]
Once login to the target has taken place, a session will have been created. To list the session information, this command is used. The session number and target information for each of the targets are displayed. If the -c flag is used, connection information is displayed as well. For more context on the exact usage of this command, please see the example below.
 
 
-n initiator-name [
-A -alias
] [
-i isid
]
Set the initiator name. The default initiator name is iqn.1994-04.org.netbsd:iscsi.<hostname>:<hostid> . An alias can be specified as well as an isid

iscsictl is intended to be used as follows:
The initiator itself can be loaded as a kernel module, and works successfully on 2.0 (the host called "burner"), running against the NetBSD target on a 5.99 host.
burner# modload -v -s -p /usr/lkm/iscsi_post.sh /usr/lkm/iscsidrv.o 
modload: reserving 36864 bytes of memory 
Module loaded as ID 0 
burner# iscsid 
iSCSI Daemon loaded 
burner# iscsictl add_send_target -a 172.16.135.133 
Added Send Target 1 
burner# iscsictl refresh_targets 
OK 
burner# iscsictl list_targets 
     1: iqn.1994-04.org.netbsd.iscsi-target:target0 
	2: 172.16.135.133:3260,1 
burner# iscsictl login -P 2 
Created Session 2, Connection 1 
burner# iscsictl list_sessions 
Session 2: Target iqn.1994-04.org.netbsd.iscsi-target:target0 
burner# newfs /dev/rsd0a 
/dev/rsd0a: 100.0MB (204800 sectors) block size 8192, fragment size 1024 
	using 4 cylinder groups of 25.00MB, 3200 blks, 6144 inodes. 
super-block backups (for fsck -b #) at: 
     32,  51232, 102432, 153632, 
burner# mount /dev/sd0a /mnt 
burner# df 
Filesystem  1K-blocks     Used     Avail Capacity  Mounted on 
/dev/wd0a     4066094   186994   3675795     4%    / 
kernfs              1        1         0   100%    /kern 
/dev/sd0a       99247        1     94283     0%    /mnt 
burner# dmesg | egrep '(scsibus|sd0)' 
scsibus0 at bha2: 16 targets, 8 luns per target 
scsibus0: waiting 2 seconds for devices to settle... 
scsibus1 at iscsi0: 1 target, 16 luns per target 
sd0 at scsibus1 target 0 lun 0: <NetBSD, NetBSD iSCSI, 0> disk fixed 
sd0: fabricating a geometry 
sd0: 100 MB, 100 cyl, 64 head, 32 sec, 512 bytes/sect x 204800 sectors 
sd0: fabricating a geometry 
sd0: fabricating a geometry 
sd0: fabricating a geometry 
burner#
and, on the target end of the iSCSI session:
Reading configuration from `/etc/iscsi/targets' 
target0:rw:0.0.0.0/0 
	extent0:/tmp/iscsi-target0:0:104857600 
DISK: 1 logical unit (204800 blocks, 512 bytes/block), type iscsi fs 
DISK: LUN 0: 100 MB disk storage for "target0" 
TARGET: iSCSI Qualified Name (IQN) is iqn.1994-04.org.netbsd.iscsi-target 
> iSCSI Discovery login  successful from iqn.1994-04.org.netbsd:iscsi.burner.cupertino.alistaircrooks.com:0 on 172.16.135.137 disk -1, ISID 70368764559360, TSIH 1 
< iSCSI Discovery logout successful from iqn.1994-04.org.netbsd:iscsi.burner.cupertino.alistaircrooks.com:0 on 172.16.135.137 disk -1, ISID 70368764559360, TSIH 1 
> iSCSI Normal login  successful from iqn.1994-04.org.netbsd:iscsi.burner.cupertino.alistaircrooks.com:0 on 172.16.135.137 disk 0, ISID 70368764559360, TSIH 2

iscsid(8)

The iscsictl utility appeared in NetBSD 6.0.

Alistair Crooks ⟨agc@NetBSD.org⟩ wrote this manual page. The iscsictl utility was contributed by Wasabi Systems, Inc.
May 26, 2012 bsd.lv