|MAKEWHATIS(8)||System Manager's Manual||MAKEWHATIS(8)|
makewhatis — index
makewhatis utility extracts keywords
from UNIX manuals and indexes them in a database for
fast retrieval by apropos(1),
makewhatis creates a
database in each dir using the files
in that directory. Existing databases are replaced. If a directory contains
no manual pages, no database is created in that directory. If
dir is not provided,
makewhatis uses the default paths stipulated by
The arguments are as follows:
-D, also show all keywords added for each file.
-p. All diagnostic messages are printed to the standard output; the standard error output is not used.
If fatal parse errors are encountered while parsing, the offending file is printed to stderr, omitted from the index, and the parse continues with the next input file.
-toption is specified.
makewhatis utility exits with one of
the following values:
makewhatisto exit at once, possibly in the middle of parsing or formatting a file. The output databases are corrupt and should be removed.
makewhatis utility first appeared in
2BSD. It was rewritten in
OpenBSD 2.7 and in C for OpenBSD
The dir argument first appeared in
NetBSD 1.0; the options
in OpenBSD 2.7; the option
-u in OpenBSD 3.4; and the
-aCDnQT in OpenBSD
Bill Joy wrote the original
makewhatis in February
1979, Marc Espie started the Perl version in 2000,
and the current version of
makewhatis was written by
|May 17, 2017||OpenBSD 6.7|