|PTA-ACCOUNTS(5)||File Formats Manual||PTA-ACCOUNTS(5)|
account definition list for plain text
The file accounts.txt in the current directory defines the accounts that can be used in the pta-journal(5) file. Like all pta(1) input files, it is an ascii(7) text file using strings of one or more space characters as the field delimiter and using the hash character (‘#’) in the first column to mark lines as ignored.
Each line in the accounts file defines one account and consists of three fields:
Usually, account numbers consist of three to five digits, to provide enough space for a systematic, hierarchical organization, such that ranges of accounts can be used for accounts of similar types and purposes. For example, as one possibility among many, an account system might use:
It is recommended but not required that all account numbers in a given bookkeeping file have the same length.
To correctly assign account types, it is crucial to remember the following distinctions.
Balances on asset, liability, and equity accounts represent sums of values. In the case of assets, these are values available to the natural or legal person doing the bookkeeping, no matter who ultimately owns them, like cash in the wallet or goods on the shelf, even if some of the goods have been bought on credit. Assets are classified according to the physical or legal form they currently take.
The sums of assets always equals the sum of equity and liabilities, but in the case of equity and liabilities, this same sum is subdivided according to who actually owns the values, and in which legal form, no matter in which physical form the value is currently available.
Equity is the value owned by the legal person themself, for example outstanding shares, private deposits by the owner of the business, and retained earnings.
Liabilities are values owed to other legal persons, for example credit card balances, accounts payable, mortgages, or issued bonds.
In contrast to assets, liabilities, and equity, revenues and expenses do not represent values at rest but changes of values, or more specifically, changes of equity, or even more specifically, changes of retained earnings. Revenues represent increases of equity; expenses represent decreases of equity.
For example, buying an apple and eating it is an expense, reducing equity. On the other hand, buying twenty boxes of apples and displaying them for sale in a shop is not an expense but acquiring a current asset (goods for sale).
If these distinctions seem confusing, designing a new account system from scratch is discouraged and using a subset of an existing, standard account system is recommended instead because misclassification of accounts is likely to yield wrong results in the balance sheet.
Statistical accounts are accounts that neither appear on the balance sheet nor in the lists of revenues and expenses. If a journal entry contains a statistical account, the contra account must be a statistical account, too. Such accounts can be used to collect supplementary data that cannot be derived from the balance sheet. One typical area where using statistical accounts can sometimes simplify bookkeeping is tax law because in some countries, tax laws and laws governing trade balances impose conflicting requirements. For example:
In contrast to many commercial accounting programs, pta(1) does not attempt to guide the user to conform to the particular bookkeeping or legal system of any country. It is entirely the responsibility of the user to define and use accounts as required by applicable law, and it is very easy to set up the accounts file and use the accounts in ways that are grossly illegal. The flip side is great flexibility, allowing to easily adapt pta(1) to many different legal systems.
Ingo Schwarze <firstname.lastname@example.org>
|October 4, 2020||OpenBSD 6.7|